上海11选5

ROS软路由论坛 9zyjao.com

 找回密码
 会员注册
查看: 947|回复: 13
打印 上一主题 下一主题

[原创] 动态ip照样可以架设ppp VP恩 服务端

[复制链接]
跳转到指定楼层
楼主
发表于 2020-4-25 15:35:10 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
ROS软路由论坛
本帖最后由 vvv888 于 2020-4-25 15:43 编辑

关键问题是怎么将动态ip告知客户端。
现在有个第三方页面可以存贮您的动态ip。
这样客户端使用脚本就可以查询更新服务器的ip地址。

1
到下面任意一个链接注册一个账号
http://www.99ht.com
http://ip.99ht.com:8077

2  以L2TP为例
请在您作为服务器端的RouterOS设备上开启VP*账号(ppp/secrets),并开启L2TP服务,然后system/scripts增加以下内容的脚本,并在计划任务(system/scheduler)中让其每60秒执行一次。
脚本中红色的user和password,分别替换为您在99ht.com注册的登陆名和密码。
{
local ipaddr
local user "user"
local psw "password"
:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
local server "http://ip.99ht.com:8077"
local par "/update.asp?user=$user&ip=$ipaddr&psw=$psw"
/tool fetch url=($server . $par) mode=http
}

3
请在您作为客户端的RouterOS设备建立好VP恩客户端。然后在system/scripts增加如下类似脚本。并添加到计划任务(system/scheduler)中每10-30秒执行一次。
游客,如果您要查看本帖隐藏内容请回复












沙发
 楼主| 发表于 2020-4-25 15:45:09 | 只看该作者
ROS软路由论坛
帖子中所有的*号  实际是字母N.   记得改哈。
地板
发表于 2020-5-4 22:05:07 | 只看该作者
楼主无敌!jj一百米长
5
发表于 2020-5-13 20:00:48 | 只看该作者
关健怎么建VP思服务端
6
发表于 2020-5-20 11:05:50 | 只看该作者
我来看看技术
7
发表于 2020-5-23 13:19:24 | 只看该作者
看看怎么搞
9
发表于 2020-5-25 13:18:21 | 只看该作者
很好  感谢
10
发表于 2020-5-26 07:01:40 | 只看该作者
不错,我要研究研究
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

不良信息举报Q:2000617

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 9zyjao.com

GMT+8, 2020-8-7 07:44 , Processed in 0.140181 second(s), 14 queries .

Powered by X3.4

上海11选5© 2001-2017

快速回复 返回顶部 返回列表