上海11选5

ROS软路由论坛 9zyjao.com

 找回密码
 会员注册
查看: 41467|回复: 387
打印 上一主题 下一主题

[Route动态路由和路由策略] [PCC 负载均衡] PCC 匹配器允许分离传输流做到平衡流量的功

  [复制链接]
跳转到指定楼层
楼主
发表于 2013-4-21 02:16:16 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
ROS软路由论坛
PCC 负载均衡

PCC 匹配器允许分离传输流做到平衡流量的功能(能指定这个属性选择 src-address, src-port, dst-address,dst-port)

PCC 原理

PCC 从一定范围内分析选择 IP 数据包头,通过哈西散列算法的帮助下,将选定的区域转换为 32bit 值。这个值 除以指定 Denominator(分母),余数将比较一个指定的余数(Remainder),如果相等这时数据包将会被 捕获,你可以选择 src-address, dst-address, src-port, dst-port 等使用此操作。

per-connection-classifier=

PerConnectionClassifier ::= [!]ValuesToHashenominator/Remainder

Remainder ::= 0..4294967295 (integer number) Denominator ::= 1..4294967295 (integer number)

ValuesToHash ::= src-address|dst-address|src-port|dst-port[,ValuesToHash*]

per-connection-classifier 分类器,通过判断源地址、目标地址、源端口和目标端口,对数据进行分类,如

事例: 这个配置将所有连接基于源地址和端口分类的 3 个组:

/ip firewall mangle add chain=prerouting action=mark-connection

new-connection-mark=1st_conn per-connection-classifier=both-addresses:3/0

/ip firewall mangle add chain=prerouting action=mark-connection

new-connection-mark=2nd_conn per-connection-classifier=both-addresses:3/1

/ip firewall mangle add chain=prerouting action=mark-connection

new-connection-mark=3rd_conn per-connection-classifier=both-addresses:3/2

per-connection-classifier=both-addresses:3/0,这条规则的含义为我们对原地址的端口进行分类,3/0 为 一共有 3 条出口,定义第一条,3/1 则是第二条,以此类推。

注意:PCC 从 RouterOS v3.24 开始支持,这个功能解决了多网关的负载均衡问题。

PCC 的负载均衡事例

一、 双向地址负载均衡

通分组源地址和源端口实现负载平衡,这里我们建立 2 个 WAN 出口分别是 wan1 和 wan2,网络环境如下:
游客,如果您要查看本帖隐藏内容请回复



y ISP1 地址 10.200.15.99/24,网关:10.200.15.1;

y ISP2 地址 10.200.100.99/24,网关:10.200.100.2;

y 内网 IP 地址 192.168.100.1/24;

y 启用 DNS 缓存功能,用 192.168.100.1 作内网 DNS 解析;

基本配置

首先进入 ip address 配置 IP 地址:
6.9.2

在 ip dns setting 中配置好 DNS 缓存,DNS 为:61.139.2.69



Mangle 标记配置

接下来我们进入 ip firewall mangle 标记连接和路由,我们使用 per-connection-classifier 双向地址进行分 类做连接分类标记。

首先我们需要将进入路由的的链接进行标记

如下图,我们进入一条 mangle 规则,中的 advanced 标签内容可以看到 per-connection-classifier 分类器, 选择 both-addresses 的分类:



然后选择 dst-address-type=!local,即除了目标地址是本地以前的地址:



注:2 条线的分类代码定义是第一条线为 2/0,第二条为 2/1



同样选择一下地址类型:



下面命令是提取走第一条线路的连接标记取名位 1st_conn,并从连接里提取路由标记名位 1st_route,设

置:per-connection-classifier=both-addresses:2/0, 设置 in-interface=lan

/ip firewall mangle

add action=mark-connection chain=prerouting comment="" disabled=no \ in-interface=lan new-connection-mark=1st_conn passthrough=yes \ per-connection-classifier=both-addresses:2/0

add action=mark-routing chain=prerouting comment="" connection-mark=1st_conn \

disabled=no in-interface=lan new-routing-mark=1st_route passthrough=yes

提取走第二条线路的连接标记取名位 2nd_conn,并从连接里提取路由标记名位 2nd_route,设置 :

per-connection-classifier=both-addresses:2/1,设置 in-interface=lan:

/ip firewall mangle

add action=mark-connection chain=prerouting comment="" disabled=no \ in-interface=lan new-connection-mark=2nd_conn passthrough=yes \ per-connection-classifier=both-addresses:2/1

add action=mark-routing chain=prerouting comment="" connection-mark=2nd_conn \

disabled=no in-interface=lan new-routing-mark=2nd_route passthrough=yes

在 winbox 在 mangle 中设置完成后如下:



回程路由设置

我们需要将从那个口进入就从相应的口回去,即保证每个外网口的数据能得到正确的路由

/ ip firewall mangle

add chain=input in-interface=wan1 action=mark-connection new-connection-mark=1st_conn

add chain=input in-interface=wan2 action=mark-connection new-connection-mark=2nd_conn

winbox 设置



标记完进入接口的链接后,将这些链接指定到相应的路由标记上:

add chain=output connection-mark=1st_conn action=mark-routing new-routing-mark=1st_route

add chain=output connection-mark=2nd_conn action=mark-routing new-routing-mark=2nd_route

winbox 设置



路由配置

配置完标记后路由后,我们进入 ip route 配置路由,首先设置负载均衡的标记路由,首先设置第一条线路的路

由标记,设置 routing-mark=1st_route:



设置第二条线路的路由标记,设置 routing-mark=2nd_route:



配置默认网关和备份网关,默认网关的 distance 设置为 1,并设置 check-gateway=ping,通过 ping 监测 网关状态:



备份网关的 distance 设置为 2,并设置 check-gateway=ping,通过 ping 监测网关状态:



配置完成后的路由标如下图:



配置 nat

最后配置 nat 转换规则,进入 ip firewall nat 中配置 action=masquerade,分别对 2 条线路做伪装:

/ip firewall nat

add action=masquerade chain=srcnat out-interface=wan1 add action=masquerade chain=srcnat out-interface=wan2



六线的 PCC 负载均衡

许多网络中会出现相同运营商,相同带宽多线路的接入,比如下面是一个 6 条线路的接入,我们通过 PCC 解决带宽的均衡,通过分类源地址和目标地址的负载均衡,即双向地址(both addresses),设置于之前的操作 基本相同,只是变成了 6 组规则.

下面是 6 条 ADSL 的情况,mangle 标记的 prerouting 规则:



进入 ip route 设置路由,这个是 PPPoE 拨号上网的策略路由配置:
游客,如果您要查看本帖隐藏内容请回复



第七章 DHCP 操作配置

DHCP(动态主机分配协议),负责分配和接收网络中的 IP 地址信息,能让网络内的主机动态获取地址,连接指定的网络。

RouterOS 支持服务端(Server)和客户端 (Client),同时支持 DHCP-relay 接力传输功能。

评分

参与人数 1A币 +10 收起 理由
derby_ma + 10 很给力!

查看全部评分

沙发
发表于 2013-4-25 08:59:56 | 只看该作者
ROS软路由论坛
学习了太详细了
板凳
发表于 2013-4-25 17:24:31 | 只看该作者
确实详细,学习中
地板
发表于 2013-4-26 09:48:54 | 只看该作者
我勒个去啊
5
发表于 2013-5-6 19:24:09 | 只看该作者
谢谢楼主共享
6
发表于 2013-5-18 12:39:36 | 只看该作者
这个可以有,回复看看先!!...
7
发表于 2013-5-25 22:07:40 | 只看该作者
该分配一个 IP 地址。物理网络连接应该建立在 HotSpot 用户的电脑和网关之间。它可以是无线(无线网卡需要在 AP 上注册),或者有线的(NIC 网卡需要连接到一个集线器或一个交换
8
发表于 2013-5-28 02:17:43 | 只看该作者
9
发表于 2013-5-28 12:14:48 | 只看该作者
vcbbfghfghfghf
10
发表于 2013-5-28 14:11:45 | 只看该作者
终于看到教程拉   找拉好久好久 不知道多久 谢谢
您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

ROS教程版块已全面开放,
即使是新注册的初级会员也可阅读全部内容。

不良信息举报Q:2000617

不良信息举报Q:2000617|Archiver|小黑屋|ROS软路由论坛 9zyjao.com

GMT+8, 2020-8-7 08:00 , Processed in 0.210391 second(s), 20 queries .

Powered by X3.4

上海11选5© 2001-2017

快速回复 返回顶部 返回列表